Project

Profile

Help

Issue #1695

repo export is copying the files over to the location not as an iso

Added by pthomas@redhat.com over 4 years ago. Updated over 1 year ago.

Status:
CLOSED - NOTABUG
Priority:
Normal
Assignee:
-
Category:
-
Sprint/Milestone:
-
Start date:
Due date:
Estimated time:
Severity:
2. Medium
Version:
Platform Release:
OS:
Triaged:
No
Groomed:
No
Sprint Candidate:
No
Tags:
Pulp 2
Sprint:
Quarter:

Description

Repo export seems seems to be just copying the files over.It is not making the repository into an iso


[root@cloud-qe-14 ~]# rpm -qa |grep pulp
pulp-rpm-consumer-extensions-2.8.0-0.5.beta.git.46.c9f2464.el7.noarch
pulp-puppet-plugins-2.8.0-0.5.beta.git.6.5894bd0.el7.noarch
pulp-rpm-admin-extensions-2.8.0-0.5.beta.git.46.c9f2464.el7.noarch
pulp-agent-2.8.0-0.5.beta.git.107.d52583d.el7.noarch
python-pulp-rpm-common-2.8.0-0.5.beta.git.46.c9f2464.el7.noarch
python-pulp-bindings-2.8.0-0.5.beta.git.107.d52583d.el7.noarch
pulp-consumer-client-2.8.0-0.5.beta.git.107.d52583d.el7.noarch
python-isodate-0.5.0-4.pulp.el7.noarch
python-pulp-docker-common-2.0.0-0.5.beta.git.29.0ebc63d.el7.noarch
python-pulp-repoauth-2.8.0-0.5.beta.git.107.d52583d.el7.noarch
pulp-rpm-plugins-2.8.0-0.5.beta.git.46.c9f2464.el7.noarch
python-pulp-streamer-2.8.0-0.5.beta.git.107.d52583d.el7.noarch
pulp-admin-client-2.8.0-0.5.beta.git.107.d52583d.el7.noarch
pulp-rpm-handlers-2.8.0-0.5.beta.git.46.c9f2464.el7.noarch
pulp-docker-plugins-2.0.0-0.5.beta.git.29.0ebc63d.el7.noarch
python-pulp-client-lib-2.8.0-0.5.beta.git.107.d52583d.el7.noarch
pulp-docker-admin-extensions-2.0.0-0.5.beta.git.29.0ebc63d.el7.noarch
pulp-puppet-consumer-extensions-2.8.0-0.5.beta.git.6.5894bd0.el7.noarch
pulp-puppet-handlers-2.8.0-0.5.beta.git.6.5894bd0.el7.noarch
python-pulp-puppet-common-2.8.0-0.5.beta.git.6.5894bd0.el7.noarch
pulp-server-2.8.0-0.5.beta.git.107.d52583d.el7.noarch
pulp-selinux-2.8.0-0.5.beta.git.107.d52583d.el7.noarch
python-pulp-agent-lib-2.8.0-0.5.beta.git.107.d52583d.el7.noarch
pulp-rpm-yumplugins-2.8.0-0.5.beta.git.46.c9f2464.el7.noarch
python-pulp-common-2.8.0-0.5.beta.git.107.d52583d.el7.noarch
python-kombu-3.0.33-2.pulp.el7.noarch
python-pulp-oid_validation-2.8.0-0.5.beta.git.107.d52583d.el7.noarch
pulp-puppet-admin-extensions-2.8.0-0.5.beta.git.6.5894bd0.el7.noarch
[root@cloud-qe-14 ~]# 

1. Create a repo with or without a --export-dir option
2. export the repo

When I ran export without the --export-dir no export directory was created

root@cloud-qe-14 ~]# pulp-admin rpm repo export run --repo-id rhel6-ks --export-dir /tmp/
+----------------------------------------------------------------------+
                    Publishing Repository [rhel6-ks]
+----------------------------------------------------------------------+

The following publish configuration options will be used:

Export Dir:  /tmp/

This command may be exited via ctrl+c without affecting the request.

Initializing repo metadata
[-]
... completed

Publishing Distribution files
[|]
... completed

Publishing RPMs
[==================================================] 100%
3819 of 3819 items
... completed

Publishing Delta RPMs
... skipped

Publishing Errata
[-]
... completed

Publishing Comps file
[==================================================] 100%
212 of 212 items
... completed

Publishing Metadata.
[-]
... completed

Closing repo metadata
[-]
... completed

Generating sqlite files
... skipped

Copying files
[\]
... completed

Writing Listings File
[-]
... completed

Task Succeeded

[root@cloud-qe-14 ~]# pulp-admin rpm repo export run --repo-id zoo --export-dir /tmp
+----------------------------------------------------------------------+
                      Publishing Repository [zoo]
+----------------------------------------------------------------------+

This command may be exited via ctrl+c without affecting the request.

Initializing repo metadata
[-]
... completed

Publishing Distribution files
[-]
... completed

Publishing RPMs
[==================================================] 100%
32 of 32 items
... completed

Publishing Delta RPMs
... skipped

Publishing Errata
[==================================================] 100%
4 of 4 items
... completed

Publishing Comps file
[==================================================] 100%
3 of 3 items
... completed

Publishing Metadata.
[-]
... completed

Closing repo metadata
[-]
... completed

Generating sqlite files
... skipped

Copying files
[-]
... completed

Writing Listings File
[-]
... completed

Exporting ISO
[-]
... completed

Moving ISO to final location
[-]
... completed

Task Succeeded

[root@cloud-qe-14 ~]# ls -l /tmp/

drwxr-xr-x. 3 apache apache    31 Feb 18 13:54 cds
drwxr-xr-x. 3 apache apache    31 Feb 18 13:50 repos
-rw-r--r--. 1 apache apache   171 Feb 18 13:54 listing

[root@cloud-qe-14 ~]# 

[root@cloud-qe-14 ~]# pulp-admin rpm repo export run --repo-id zoo 
+----------------------------------------------------------------------+
                      Publishing Repository [zoo]
+----------------------------------------------------------------------+

This command may be exited via ctrl+c without affecting the request.

Initializing repo metadata
[-]
... completed

Publishing Distribution files
[-]
... completed

Publishing RPMs
[==================================================] 100%
32 of 32 items
... completed

Publishing Delta RPMs
... skipped

Publishing Errata
[==================================================] 100%
4 of 4 items
... completed

Publishing Comps file
[==================================================] 100%
3 of 3 items
... completed

Publishing Metadata.
[-]
... completed

Closing repo metadata
[-]
... completed

Generating sqlite files
... skipped

Copying files
[-]
... completed

Writing Listings File
[-]
... completed

Exporting ISO
[-]
... completed

Moving ISO to final location
[-]
... completed

Task Succeeded

[root@cloud-qe-14 ~]# ls -l /var/lib/pulp/
content/   published/ sn.dat     static/    uploads/   
[root@cloud-qe-14 ~]# ls -l /var/lib/pulp/published/
total 0
drwxr-xr-x. 3 apache apache 15 Feb 17 13:31 docker
drwxr-xr-x. 4 apache apache 29 Feb 17 11:26 puppet
drwxr-xr-x. 5 apache apache 42 Feb 17 13:56 yum

History

#1 Updated by mhrivnak over 4 years ago

Please provide full reproducer steps. I could assume that you created the zoo repo with all default options and only specified a feed, but I don't want to make assumptions.

Also, can you elaborate on why you're looking in /tmp/?

#2 Updated by mhrivnak over 4 years ago

Also, what version of pulp is this? And what OS?

#3 Updated by pthomas@redhat.com over 4 years ago

  • Description updated (diff)

#4 Updated by pthomas@redhat.com over 4 years ago

  • Description updated (diff)

#5 Updated by mhrivnak over 4 years ago

Works for me on current master. I did:

pulp-admin rpm repo create --repo-id=zoo --feed=https://repos.fedorapeople.org/repos/pulp/pulp/demo_repos/zoo/
pulp-admin rpm repo sync run --repo-id=zoo
pulp-admin rpm repo export run --repo-id=zoo

and then

$ ls /var/lib/pulp/published/yum/master/export_distributor/zoo/1455827472.54/
zoo-2016-02-18T20.31-01.iso

#6 Updated by pthomas@redhat.com over 4 years ago

When I don't have an --export-dir specified, I see that as well. But with --export-dir specified, the .iso file is missing

root@cloud-qe-9 ~]# pulp-admin rpm repo export run --repo-id zoo
--------------------------------------------------------------------
Publishing Repository [zoo]
--------------------------------------------------------------------

This command may be exited via ctrl+c without affecting the request.

Initializing repo metadata
[-]
... completed

Publishing Distribution files
[-]
... completed

Publishing RPMs
[==================================================] 100%
32 of 32 items
... completed

Publishing Delta RPMs
... skipped

Publishing Errata
[==================================================] 100%
4 of 4 items
... completed

Publishing Comps file
[==================================================] 100%
3 of 3 items
... completed

Publishing Metadata.
[-]
... completed

Closing repo metadata
[-]
... completed

Generating sqlite files
... skipped

Copying files
[-]
... completed

Writing Listings File
[-]
... completed

Exporting ISO
[-]
... completed

Moving ISO to final location
[-]
... completed

Task Succeeded

[root@cloud-qe-9 ~]# ls l /var/lib/pulp/published/yum/master/export_distributor/zoo/1455827385.92/
total 520
-rw-r--r-
. 1 apache apache 532480 Feb 18 15:29 zoo-2016-02-18T20.29-01.iso
[root@cloud-qe-9 ~]#
[root@cloud-qe-9 ~]#

[root@cloud-qe-9 ~]# pulp-admin rpm repo export run --repo-id zoo --export-dir /tmp
--------------------------------------------------------------------
Publishing Repository [zoo]
--------------------------------------------------------------------

The following publish configuration options will be used:

Export Dir: /tmp

This command may be exited via ctrl+c without affecting the request.

Initializing repo metadata
[-]
... completed

Publishing Distribution files
[-]
... completed

Publishing RPMs
[==================================================] 100%
32 of 32 items
... completed

Publishing Delta RPMs
... skipped

Publishing Errata
[==================================================] 100%
4 of 4 items
... completed

Publishing Comps file
[==================================================] 100%
3 of 3 items
... completed

Publishing Metadata.
[-]
... completed

Closing repo metadata
[-]
... completed

Generating sqlite files
... skipped

Copying files
[-]
... completed

Writing Listings File
[-]
... completed

Task Succeeded

[root@cloud-qe-9 ~]# ls -l /tmp/
.font-unix/
.ICE-unix/
ks-script-8YLnL6
ks-script-a1BRcM
ks-script-IJVzRm
listing
repos/
systemd-private-43a032f74ea9447fbae57f983b7a588d-httpd.service-MjEr8m/
systemd-private-43a032f74ea9447fbae57f983b7a588d-mongod.service-UcnDwI/
.Test-unix/
tmp.4hapB5
.X11-unix/
.XIM-unix/
yum.log
[root@cloud-qe-9 ~]# ls -l /tmp/repos/
listing pulp/
[root@cloud-qe-9 ~]# ls -l /tmp/repos/pulp/
listing pulp/
[root@cloud-qe-9 ~]# ls -l /tmp/repos/pulp/pulp/
demo_repos/ listing
[root@cloud-qe-9 ~]# ls -l /tmp/repos/pulp/pulp/demo_repos/
listing zoo/
[root@cloud-qe-9 ~]# ls -l /tmp/repos/pulp/pulp/demo_repos/
listing zoo/
[root@cloud-qe-9 ~]# ls -l /tmp/repos/pulp/pulp/demo_repos/zoo/
bear-4.1-1.noarch.rpm kangaroo-0.2-1.noarch.rpm
camel-0.1-1.noarch.rpm lion-0.4-1.noarch.rpm
cat-1.0-1.noarch.rpm mouse-0.1.12-1.noarch.rpm
cheetah-1.25.3-5.noarch.rpm penguin-0.9.1-1.noarch.rpm
chimpanzee-0.21-1.noarch.rpm pike-2.2-1.noarch.rpm
cockateel-3.1-1.noarch.rpm repodata/
cow-2.2-3.noarch.rpm shark-0.1-1.noarch.rpm
crow-0.8-1.noarch.rpm squirrel-0.1-1.noarch.rpm
dog-4.23-1.noarch.rpm stork-0.12-2.noarch.rpm
dolphin-3.10.232-1.noarch.rpm tiger-1.0-4.noarch.rpm
duck-0.6-1.noarch.rpm trout-0.12-1.noarch.rpm
elephant-8.3-1.noarch.rpm walrus-0.71-1.noarch.rpm
fox-1.1-2.noarch.rpm walrus-5.21-1.noarch.rpm
frog-0.1-1.noarch.rpm whale-0.2-1.noarch.rpm
giraffe-0.67-2.noarch.rpm wolf-9.4-2.noarch.rpm
gorilla-0.62-1.noarch.rpm zebra-0.1-2.noarch.rpm
horse-0.22-2.noarch.rpm

#7 Updated by mhrivnak over 4 years ago

  • Status changed from NEW to CLOSED - NOTABUG

From the docs for the "export_dir" option, found at http://pulp-rpm.readthedocs.org/en/latest/tech-reference/export-distributor.html

"A full path to an export directory. If this option is specified, the repositories are not placed in ISO images and published over HTTP or HTTPS. Instead, they are written to the export directory. This option is useful if exporting to an external hard drive, for example."

A similar description appears in the pulp-admin help text for that option.

#8 Updated by pthomas@redhat.com over 4 years ago

Just curios though why the export directory is not getting created.

For example in 2.7 here is what I have

[cloud-user@pulp-server ~]$ rpm -qa |grep pulp
python-isodate-0.5.0-4.pulp.el7.noarch
python-kombu-3.0.24-10.pulp.el7.noarch
python-pulp-puppet-common-2.7.1-1.el7.noarch
pulp-selinux-2.7.1-1.el7.noarch
pulp-admin-client-2.7.1-1.el7.noarch
python-pulp-ostree-common-1.0.0-1.el7.noarch
pulp-docker-plugins-1.0.2-1.el7.noarch
python-pulp-common-2.7.1-1.el7.noarch
python-pulp-rpm-common-2.7.1-1.el7.noarch
python-pulp-oid_validation-2.7.1-1.el7.noarch
pulp-server-2.7.1-1.el7.noarch
pulp-puppet-plugins-2.7.1-1.el7.noarch
python-pulp-bindings-2.7.1-1.el7.noarch
python-pulp-client-lib-2.7.1-1.el7.noarch
pulp-puppet-admin-extensions-2.7.1-1.el7.noarch
pulp-ostree-plugins-1.0.0-1.el7.noarch
pulp-docker-admin-extensions-1.0.2-1.el7.noarch
python-pulp-repoauth-2.7.1-1.el7.noarch
pulp-rpm-plugins-2.7.1-1.el7.noarch
pulp-rpm-admin-extensions-2.7.1-1.el7.noarch
pulp-ostree-admin-extensions-1.0.0-1.el7.noarch
python-pulp-docker-common-1.0.2-1.el7.noarch
[cloud-user@pulp-server ~]$

[cloud-user@pulp-server ~]$ pulp-admin rpm repo export run --repo-id upload
--------------------------------------------------------------------
Publishing Repository [upload]
--------------------------------------------------------------------

This command may be exited via ctrl+c without affecting the request.

[/]
Waiting to begin...
Initializing repo metadata
[\]
... completed

Publishing Distribution files
[-]
... completed

Publishing RPMs
[\]
... completed

Publishing Delta RPMs
... skipped

Publishing Errata
[-]
... completed

Publishing Comps file
[\]
... completed

Publishing Metadata.
[-]
... completed

Closing repo metadata
[-]
... completed

Generating sqlite files
... skipped

Copying files
[-]
... completed

Writing Listings File
[-]
... completed

Exporting ISO
[/]
... completed

Moving ISO to final location
[-]
... completed

Task Succeeded

[cloud-user@pulp-server ~]$ sudo ls l /var/lib/pulp/published/yum/http/
total 0
drwxr-x--
. 3 apache apache 18 Feb 18 16:22 exports
drwxr-x---. 3 apache apache 43 Feb 10 09:37 repos
[cloud-user@pulp-server ~]$ sudo ls l /var/lib/pulp/published/yum/http/exports/
total 0
drwxr-x--
. 2 apache apache 19 Feb 18 16:22 repos

#9 Updated by bmbouter over 1 year ago

  • Tags Pulp 2 added

Please register to edit this issue

Also available in: Atom PDF