Project

Profile

Help

Issue #1690

Unable install rpm from a repo that has on_demand download policy.

Added by pthomas@redhat.com over 4 years ago. Updated over 1 year ago.

Status:
CLOSED - NOTABUG
Priority:
Normal
Assignee:
-
Category:
-
Sprint/Milestone:
-
Start date:
Due date:
Estimated time:
Severity:
2. Medium
Version:
Platform Release:
OS:
Triaged:
No
Groomed:
No
Sprint Candidate:
No
Tags:
Pulp 2
Sprint:
Quarter:

Description

rpm install fails when trying to install from a repository that is synced with an on_demand download policy

1. Create and sync a repo with on_demand download policy
pulp-admin rpm repo create --repo-id zoo --feed https://repos.fedorapeople.org/repos/pulp/pulp/demo_repos/zoo/   --download-policy on_demand

pulp-admin rpm repo sync run --repo-id zoo

2. Register a consumer and bind the zoo repo to the consumer

pulp-consumer -u admin -p admin register --consumer-id starfish

pulp-admin rpm consumer bind --repo-id zoo --consumer-id starfish

3. Install an rpm
 pulp-admin rpm consumer   package install run --name cat --consumer-id starfish

[root@cloud-qe-14 ~]# rpm -qa |grep pulp
pulp-rpm-consumer-extensions-2.8.0-0.5.beta.git.46.c9f2464.el7.noarch
pulp-puppet-plugins-2.8.0-0.5.beta.git.6.5894bd0.el7.noarch
pulp-rpm-admin-extensions-2.8.0-0.5.beta.git.46.c9f2464.el7.noarch
pulp-agent-2.8.0-0.5.beta.git.107.d52583d.el7.noarch
python-pulp-rpm-common-2.8.0-0.5.beta.git.46.c9f2464.el7.noarch
python-pulp-bindings-2.8.0-0.5.beta.git.107.d52583d.el7.noarch
pulp-consumer-client-2.8.0-0.5.beta.git.107.d52583d.el7.noarch
python-isodate-0.5.0-4.pulp.el7.noarch
python-pulp-docker-common-2.0.0-0.5.beta.git.29.0ebc63d.el7.noarch
python-pulp-repoauth-2.8.0-0.5.beta.git.107.d52583d.el7.noarch
pulp-rpm-plugins-2.8.0-0.5.beta.git.46.c9f2464.el7.noarch
python-pulp-streamer-2.8.0-0.5.beta.git.107.d52583d.el7.noarch
pulp-admin-client-2.8.0-0.5.beta.git.107.d52583d.el7.noarch
pulp-rpm-handlers-2.8.0-0.5.beta.git.46.c9f2464.el7.noarch
pulp-docker-plugins-2.0.0-0.5.beta.git.29.0ebc63d.el7.noarch
python-pulp-client-lib-2.8.0-0.5.beta.git.107.d52583d.el7.noarch
pulp-docker-admin-extensions-2.0.0-0.5.beta.git.29.0ebc63d.el7.noarch
pulp-puppet-consumer-extensions-2.8.0-0.5.beta.git.6.5894bd0.el7.noarch
pulp-puppet-handlers-2.8.0-0.5.beta.git.6.5894bd0.el7.noarch
python-pulp-puppet-common-2.8.0-0.5.beta.git.6.5894bd0.el7.noarch
pulp-server-2.8.0-0.5.beta.git.107.d52583d.el7.noarch
pulp-selinux-2.8.0-0.5.beta.git.107.d52583d.el7.noarch
python-pulp-agent-lib-2.8.0-0.5.beta.git.107.d52583d.el7.noarch
pulp-rpm-yumplugins-2.8.0-0.5.beta.git.46.c9f2464.el7.noarch
python-pulp-common-2.8.0-0.5.beta.git.107.d52583d.el7.noarch
python-kombu-3.0.33-2.pulp.el7.noarch
python-pulp-oid_validation-2.8.0-0.5.beta.git.107.d52583d.el7.noarch
pulp-puppet-admin-extensions-2.8.0-0.5.beta.git.6.5894bd0.el7.noarch
[root@cloud-qe-14 ~]#


[root@cloud-qe-14 ~]# pulp-admin repo list --repo-id zoo --details
+----------------------------------------------------------------------+
                              Repositories
+----------------------------------------------------------------------+

Id:                   zoo
Display Name:         None
Description:          None
Content Unit Counts:  
  Erratum:          4
  Package Category: 1
  Package Group:    2
  Rpm:              32
Notes:                
Scratchpad:          
  Checksum Type: sha256
Importers:            
  Config:          
    Download Policy: on_demand
    Feed:            https://repos.fedorapeople.org/repos/pulp/pulp/demo_repos/z
                     oo/
  Id:               yum_importer
  Importer Type Id: yum_importer
  Last Sync:        2016-02-17T19:25:08Z
  Repo Id:          zoo
  Scratchpad:      
    Previous Skip List:
    Repomd Revision:    1331832478
Distributors:        
  Auto Publish:        True
  Config:              
    Checksum Type: sha256
    Http:          False
    Https:         True
    Relative URL:  repos/pulp/pulp/demo_repos/zoo/
  Distributor Type Id: yum_distributor
  Id:                  yum_distributor
  Last Publish:        2016-02-17T19:25:08Z
  Repo Id:             zoo
  Scratchpad:          
  Auto Publish:        False
  Config:              
    Http:         False
    Https:        True
    Relative URL: repos/pulp/pulp/demo_repos/zoo/
  Distributor Type Id: export_distributor
  Id:                  export_distributor
  Last Publish:        None
  Repo Id:             zoo
  Scratchpad:          


[root@cloud-qe-14 ~]# pulp-admin rpm repo content rpm --repo-id zoo --str-eq "name=cat"
Arch:         noarch
Buildhost:    smqe-ws15
Checksum:     43e77adb7f51b5542b813024a8ee3e477175c142f35982ab5ae2b2978486239f
Checksumtype: sha256
Description:  A dummy package of cat
Epoch:        0
Filename:     cat-1.0-1.noarch.rpm
License:      GPLv2
Name:         cat
Provides:     cat = 1.0-1-0
Release:      1
Requires:    
Version:      1.0


[root@cloud-qe-14 ~]# pulp-admin consumer list --details
+----------------------------------------------------------------------+
                               Consumers
+----------------------------------------------------------------------+

Id:            goldfish
Display Name:  goldfish
Bindings:      
  Confirmed:   zoo
  Unconfirmed:
Capabilities:  
Description:   None
Notes:        
Rsa Pub:       -----BEGIN PUBLIC KEY-----
               MIIBIjANBgkqhkiG9w0BAQEFAAOCAQ8AMIIBCgKCAQEAqnfSZ8KnVkC+4Yz1rT41
               ur2tqUOX8qQOEpKhCCM1HcvnwpzWD8wF0pGcMiwAaJvvDpf+WN9WL+3LZNTypuc8
               SUnpL8DhofezI7NSTETe0ICp4CBGYmW/7N354g8Smn5eDF1haikg+oJllSHrI6jo
               DD0gjhQN4DgBEe5eqqhcacvnvAyLpREipEb3QqueH0aXgw+8BDdI/N3NAxJeGc6x
               l5G2WfSgRuS57xbTspE3HMYfbcwbcw5b1oWtOl99YToUTdlBJ3g0tbytTI7Qce+E
               X3X4USfeo7/S0lF7dm3sRGGMutj7+lyZIGcPsvHd2tC1gbDhNdXH3WTxUkc//Blg
               bQIDAP// -----END PUBLIC KEY-----


Id:            starfish
Display Name:  starfish
Bindings:      
  Confirmed:   zoo
  Unconfirmed:
Capabilities:  
Description:   rhel 7
Notes:        
  Consumer: rhel7
Rsa Pub:       -----BEGIN PUBLIC KEY-----
               MIIBIjANBgkqhkiG9w0BAQEFAAOCAQ8AMIIBCgKCAQEA2UbmsDnGB4FZHGswnwOL
               cNq1JvsFH9i9dN1KkMbLNjYh6xbK8fVwKr6rQFG2c3pOrZhTjH9Q0RB3sGEU8BOD
               KXzg2ya0MpJQRj0oueNRZZw6hs8/+bYTr4Dfr3O/OkFDDrsX9p/0QlBsBdyxdcxh
               U2yrBxXhL2BPZFmAEtwrv/4huPg3uiGin0UvkTwyeJ5kq5kB0ToBwwafU2WTEPmH
               CDkueS1K1WWghD6H9zSCJKFUZzB5Bvt3sye/7znlUlNnNZFEfztla4aQU/TZlI/y
               L90wUzfYQcmICI6efN1+jttNTziOfSPyghuI3fCJ/NS2rFMwW74udF1hlnVFkLi9
               VwIDAP// -----END PUBLIC KEY-----


[root@cloud-qe-14 ~]#


[root@cloud-qe-14 ~]# pulp-admin rpm consumer   package install run --name cat --consumer-id starfish
Install task created with id [ 1edbfbb0-2053-4bf8-b2dc-a0c6538b0d6f ]

This command may be exited via ctrl+c without affecting the request.

Refresh Repository Metadata             [ OK ]
Downloading Packages                    [ FAILED ]

Install Failed

[u'Errors were encountered while downloading packages.', u'cat-1.0-1.noarch:
[Errno 256] No more mirrors to try.']



Feb 18 09:59:52 cloud-qe-14.idmqe.lab.eng.bos.redhat.com pulp[30185]: pulp.server.agent.direct.services:INFO: (30185-59456) Task RMI (succeeded): Succeeded
Feb 18 09:59:52 cloud-qe-14.idmqe.lab.eng.bos.redhat.com pulp[30185]: pulp.server.agent.direct.services:INFO: (30185-59456)   sn : 07581414-4f68-44e2-af6e-d7793e7cfd53
Feb 18 09:59:52 cloud-qe-14.idmqe.lab.eng.bos.redhat.com pulp[30185]: pulp.server.agent.direct.services:INFO: (30185-59456)   origin : None
Feb 18 09:59:52 cloud-qe-14.idmqe.lab.eng.bos.redhat.com pulp[30185]: pulp.server.agent.direct.services:INFO: (30185-59456)   timestamp : 2016-02-18T14:59:52Z
Feb 18 09:59:52 cloud-qe-14.idmqe.lab.eng.bos.redhat.com pulp[30185]: pulp.server.agent.direct.services:INFO: (30185-59456)   user data : {'task_id': '1edbfbb0-2053-4bf8-b2dc-a0c6538b0d6f', 'consumer_id': 'starfish'}
Feb 18 09:59:52 cloud-qe-14.idmqe.lab.eng.bos.redhat.com pulp[30185]: pulp.server.agent.direct.services:INFO: (30185-59456)   retval:
Feb 18 09:59:52 cloud-qe-14.idmqe.lab.eng.bos.redhat.com pulp[30185]: pulp.server.agent.direct.services:INFO: (30185-59456) {'reboot': {'scheduled': False, 'details': {}}, 'details': {'rpm': {'details': {'message': "[u'Errors were encountered while downloading packages.', u'cat-1.0-1.noarch: [Errno 256] No more mirrors to try.']", 'trace': 'Traceback (most recent call last):\n\n  File "/usr/lib/python2.7/site-packages/pulp/agent/lib/dispatcher.py", line 61, in install\n    _report = handler.install(conduit, units, dict(options))\n\n  File "/usr/lib/python2.7/site-packages/pulp_rpm/handlers/rpm.py", line 100, in install\n    details = pkg.install(names)\n\n  File "/usr/lib/python2.7/site-packages/pulp_rpm/handlers/rpmtools.py", line 159, in install\n    yb.processTransaction()\n\n  File "/usr/lib/python2.7/site-packages/pulp_rpm/handlers/rpmtools.py", line 604, in processTransaction\n    YumBase.processTransaction(self, callback, rpmDisplay=display)\n\n  File "/usr/lib/python2.7/site-packages/yum/__init__.py", line 6496, in processTransaction\n    pkgs = self._downloadPackages(callback)\n\n  File "/usr/lib/python2.7/site-packages/yum/__init__.py", line 6531, in _downloadPackages\n    raise Errors.YumDownloadError, errstr\n\nYumDownloadError: [u\'Errors were encountered while downloading packages.\', u\'cat-1.0-1.noarch: [Errno 256] No more mirrors to try.\']\n'}, 'succeeded': False}}, 'succeeded': False, 'num_changes': 0}
log (5.49 KB) log pthomas@redhat.com, 02/18/2016 04:54 PM
log.txt (5.49 KB) log.txt pthomas@redhat.com, 02/18/2016 04:56 PM

History

#1 Updated by pthomas@redhat.com over 4 years ago

ssl_request_log 

[18/Feb/2016:10:32:22 -0500] 10.16.96.101 TLSv1.2 ECDHE-RSA-AES256-GCM-SHA384 "POST /pulp/api/v2/consumers/starfish/actions/content/install/ HTTP/1.1" 172
[18/Feb/2016:10:32:23 -0500] 10.16.96.101 TLSv1.2 ECDHE-RSA-AES256-GCM-SHA384 "GET /pulp/api/v2/tasks/d5492fbd-5357-4c33-b167-6fb994880cff/ HTTP/1.1" 541
[18/Feb/2016:10:32:24 -0500] 10.16.96.101 TLSv1.2 ECDHE-RSA-AES256-GCM-SHA384 "GET /pulp/api/v2/tasks/d5492fbd-5357-4c33-b167-6fb994880cff/ HTTP/1.1" 604
[18/Feb/2016:10:32:25 -0500] 10.16.96.101 TLSv1.2 ECDHE-RSA-AES256-GCM-SHA384 "GET /pulp/repos/repos/pulp/pulp/demo_repos/zoo/cat-1.0-1.noarch.rpm HTTP/1.1" -
[18/Feb/2016:10:32:25 -0500] 10.16.96.101 TLSv1.2 ECDHE-RSA-AES256-GCM-SHA384 "GET /streamer/var/lib/pulp/content/units/rpm/9a/f5588032a98f9fca7f3f6c0db7174b044beb914f9b71efa8af514ad0e81d0a/cat-1.0-1.noarch.rpm?policy=eyJleHRlbnNpb25zIjogeyJyZW1vdGVfaXAiOiAiMTAuMTYuOTYuMTAxIn0sICJyZXNvdXJjZSI6ICIvc3RyZWFtZXIvdmFyL2xpYi9wdWxwL2NvbnRlbnQvdW5pdHMvcnBtLzlhL2Y1NTg4MDMyYTk4ZjlmY2E3ZjNmNmMwZGI3MTc0YjA0NGJlYjkxNGY5YjcxZWZhOGFmNTE0YWQwZTgxZDBhL2NhdC0xLjAtMS5ub2FyY2gucnBtIiwgImV4cGlyYXRpb24iOiAxNDU1ODA5NjM1fQ%3D%3D;signature=sGWCa8gV7df6Wj5jSyHC7em1iaDe-4um9jwrW0cruJflXh4We1xpfZG_wM0IAL9zVwHhnRhxUz8amNW7bTKgQx-Ot_n1N0kilY4NvbvyzOLFq63X66QJ8VkXtAL8BE_rOutGF2gfbbRs0nxx3QdDax5NJ2O2IsIj0ZQmYbG4Ae3JPPlgQtPs0lKe-R6GWJH8QFMzOvoxMQN6AFK-DUPakYEpm6Yt5GFN6xwfpOmJGvpmvANexhzFkfXP6o_40gP4yUa-6Cs0NnQRIe5kZTwQW6L4n-k07Qo-F9488fetXF3G3H2ELNVZAnhqw3zPcKtAMLRtxwxCSkm9oE-4tLn-8A%3D%3D HTTP/1.1" 3818
[18/Feb/2016:10:32:25 -0500] 10.16.96.101 TLSv1.2 ECDHE-RSA-AES256-GCM-SHA384 "GET /pulp/repos/repos/pulp/pulp/demo_repos/zoo/cat-1.0-1.noarch.rpm HTTP/1.1" -
[18/Feb/2016:10:32:25 -0500] 10.16.96.101 TLSv1.2 ECDHE-RSA-AES256-GCM-SHA384 "GET /streamer/var/lib/pulp/content/units/rpm/9a/f5588032a98f9fca7f3f6c0db7174b044beb914f9b71efa8af514ad0e81d0a/cat-1.0-1.noarch.rpm?policy=eyJleHRlbnNpb25zIjogeyJyZW1vdGVfaXAiOiAiMTAuMTYuOTYuMTAxIn0sICJyZXNvdXJjZSI6ICIvc3RyZWFtZXIvdmFyL2xpYi9wdWxwL2NvbnRlbnQvdW5pdHMvcnBtLzlhL2Y1NTg4MDMyYTk4ZjlmY2E3ZjNmNmMwZGI3MTc0YjA0NGJlYjkxNGY5YjcxZWZhOGFmNTE0YWQwZTgxZDBhL2NhdC0xLjAtMS5ub2FyY2gucnBtIiwgImV4cGlyYXRpb24iOiAxNDU1ODA5NjM1fQ%3D%3D;signature=sGWCa8gV7df6Wj5jSyHC7em1iaDe-4um9jwrW0cruJflXh4We1xpfZG_wM0IAL9zVwHhnRhxUz8amNW7bTKgQx-Ot_n1N0kilY4NvbvyzOLFq63X66QJ8VkXtAL8BE_rOutGF2gfbbRs0nxx3QdDax5NJ2O2IsIj0ZQmYbG4Ae3JPPlgQtPs0lKe-R6GWJH8QFMzOvoxMQN6AFK-DUPakYEpm6Yt5GFN6xwfpOmJGvpmvANexhzFkfXP6o_40gP4yUa-6Cs0NnQRIe5kZTwQW6L4n-k07Qo-F9488fetXF3G3H2ELNVZAnhqw3zPcKtAMLRtxwxCSkm9oE-4tLn-8A%3D%3D HTTP/1.1" 4085
[18/Feb/2016:10:32:25 -0500] 10.16.96.101 TLSv1.2 ECDHE-RSA-AES256-GCM-SHA384 "GET /pulp/api/v2/tasks/d5492fbd-5357-4c33-b167-6fb994880cff/ HTTP/1.1" 1980

ssl_access_log

10.16.96.101 - - [18/Feb/2016:10:33:58 -0500] "POST /pulp/api/v2/consumers/starfish/actions/content/install/ HTTP/1.1" 202 172
10.16.96.101 - - [18/Feb/2016:10:33:59 -0500] "GET /pulp/api/v2/tasks/96cfa355-45f4-4008-9c1a-5543c7a9a06b/ HTTP/1.1" 200 541
10.16.96.101 - - [18/Feb/2016:10:34:00 -0500] "GET /pulp/api/v2/tasks/96cfa355-45f4-4008-9c1a-5543c7a9a06b/ HTTP/1.1" 200 604
10.16.96.101 - - [18/Feb/2016:10:34:01 -0500] "GET /pulp/repos/repos/pulp/pulp/demo_repos/zoo/cat-1.0-1.noarch.rpm HTTP/1.1" 302 -
10.16.96.101 - - [18/Feb/2016:10:34:01 -0500] "GET /streamer/var/lib/pulp/content/units/rpm/9a/f5588032a98f9fca7f3f6c0db7174b044beb914f9b71efa8af514ad0e81d0a/cat-1.0-1.noarch.rpm?policy=eyJleHRlbnNpb25zIjogeyJyZW1vdGVfaXAiOiAiMTAuMTYuOTYuMTAxIn0sICJyZXNvdXJjZSI6ICIvc3RyZWFtZXIvdmFyL2xpYi9wdWxwL2NvbnRlbnQvdW5pdHMvcnBtLzlhL2Y1NTg4MDMyYTk4ZjlmY2E3ZjNmNmMwZGI3MTc0YjA0NGJlYjkxNGY5YjcxZWZhOGFmNTE0YWQwZTgxZDBhL2NhdC0xLjAtMS5ub2FyY2gucnBtIiwgImV4cGlyYXRpb24iOiAxNDU1ODA5NzMxfQ%3D%3D;signature=luNf3xFs3ENNFx4AcFXDWMXt_WYa8AA8459NTC6l-NcMQiKvZ2UNxY9VOvZ4GFFDTDkivU1gbcgCpQ015WiDWMkj4bZkdwjk7UPl3AaqpS-YQoZn5vB361flx05YZCRisk8pDuz7rtX-w2-1PsAvXt5xDBiFz1DnJNucjJU30FzkJM1Dfr6tzPLhSR8djgDA8LKiNC_25ddRoKdRNVqb6A5Ukp9nFjdb9LaU8h5WAsJdl8j7rgmg2tsSKoQRUETsudv2mF92uYJS4EyKBkVDvcWWnvoJ08lUPrEbDbFIU2-4_9RhNBZ9xOL372diBmmcwLZUWO2gIFbNcWIoGfyoOQ%3D%3D HTTP/1.1" 500 4085
10.16.96.101 - - [18/Feb/2016:10:34:01 -0500] "GET /pulp/api/v2/tasks/96cfa355-45f4-4008-9c1a-5543c7a9a06b/ HTTP/1.1" 200 1980

#2 Updated by pthomas@redhat.com over 4 years ago

#3 Updated by pthomas@redhat.com over 4 years ago

#4 Updated by pthomas@redhat.com over 4 years ago

  • Status changed from NEW to CLOSED - NOTABUG

The issue was due to pulp_streamer not running.

#5 Updated by bmbouter over 1 year ago

  • Tags Pulp 2 added

Please register to edit this issue

Also available in: Atom PDF