Project

Profile

Help

Issue #1681

Stand alone install of pulp-consumer is failing with missing dependency

Added by pthomas@redhat.com over 4 years ago. Updated over 1 year ago.

Status:
CLOSED - NOTABUG
Priority:
Normal
Assignee:
-
Start date:
Due date:
Estimated time:
Severity:
2. Medium
Version - Packaging:
Platform Release:
Target Release - Packaging:
OS:
Triaged:
No
Groomed:
No
Sprint Candidate:
No
Tags:
Pulp 2
Sprint:
Quarter:

Description

Installing pulp-consumer by itself on a system is failing with following dependency

[root@celeno ~]#
[root@celeno ~]# sudo yum groupinstall pulp-consumer-qpid
Loaded plugins: product-id, security, subscription-manager
This system is not registered to Red Hat Subscription Management. You can use subscription-manager to register.
Setting up Group Process
beaker-HighAvailability/group_gz                         | 4.0 kB     00:00    
beaker-LoadBalancer/group_gz                             | 2.1 kB     00:00    
beaker-ResilientStorage/group_gz                         | 5.6 kB     00:00    
beaker-ScalableFileSystem/group_gz                       | 2.7 kB     00:00    
beaker-Server/group_gz                                   | 211 kB     00:00    
beaker-Server-SAP/group_gz                               |  585 B     00:00    
beaker-Server-SAPHANA/group_gz                           |  391 B     00:00    
beaker-Server-optional/group_gz                          | 5.8 kB     00:00    
epel/group_gz                                            | 149 kB     00:00    
pulp-2.7-beta/group_gz                                   |  536 B     00:00    
Resolving Dependencies
--> Running transaction check
---> Package pulp-agent.noarch 0:2.8.0-0.5.beta.git.107.d52583d.el6 will be installed
--> Processing Dependency: python-pulp-bindings = 2.8.0 for package: pulp-agent-2.8.0-0.5.beta.git.107.d52583d.el6.noarch
--> Processing Dependency: python-pulp-agent-lib = 2.8.0 for package: pulp-agent-2.8.0-0.5.beta.git.107.d52583d.el6.noarch
--> Processing Dependency: python-gofer >= 2.5 for package: pulp-agent-2.8.0-0.5.beta.git.107.d52583d.el6.noarch
--> Processing Dependency: gofer >= 2.5 for package: pulp-agent-2.8.0-0.5.beta.git.107.d52583d.el6.noarch
---> Package pulp-consumer-client.noarch 0:2.8.0-0.5.beta.git.107.d52583d.el6 will be installed
--> Processing Dependency: python-pulp-common = 2.8.0 for package: pulp-consumer-client-2.8.0-0.5.beta.git.107.d52583d.el6.noarch
--> Processing Dependency: python-pulp-client-lib = 2.8.0 for package: pulp-consumer-client-2.8.0-0.5.beta.git.107.d52583d.el6.noarch
---> Package pulp-puppet-consumer-extensions.noarch 0:2.8.0-0.5.beta.git.6.5894bd0.el6 will be installed
--> Processing Dependency: python-pulp-puppet-common = 2.8.0 for package: pulp-puppet-consumer-extensions-2.8.0-0.5.beta.git.6.5894bd0.el6.noarch
---> Package pulp-puppet-handlers.noarch 0:2.8.0-0.5.beta.git.6.5894bd0.el6 will be installed
--> Processing Dependency: puppet >= 2.7.14 for package: pulp-puppet-handlers-2.8.0-0.5.beta.git.6.5894bd0.el6.noarch
---> Package pulp-rpm-consumer-extensions.noarch 0:2.8.0-0.5.beta.git.46.c9f2464.el6 will be installed
---> Package pulp-rpm-handlers.noarch 0:2.8.0-0.5.beta.git.46.c9f2464.el6 will be installed
--> Processing Dependency: python-pulp-rpm-common = 2.8.0 for package: pulp-rpm-handlers-2.8.0-0.5.beta.git.46.c9f2464.el6.noarch
---> Package pulp-rpm-yumplugins.noarch 0:2.8.0-0.5.beta.git.46.c9f2464.el6 will be installed
---> Package python-gofer-qpid.noarch 0:2.6.6-2.el6 will be installed
--> Processing Dependency: python-qpid >= 0.18 for package: python-gofer-qpid-2.6.6-2.el6.noarch
--> Running transaction check
---> Package gofer.noarch 0:2.6.6-2.el6 will be installed
---> Package puppet.noarch 0:2.7.26-2.el6 will be installed
--> Processing Dependency: facter < 1:2.0 for package: puppet-2.7.26-2.el6.noarch
--> Processing Dependency: ruby(abi) >= 1.8 for package: puppet-2.7.26-2.el6.noarch
--> Processing Dependency: ruby >= 1.8.5 for package: puppet-2.7.26-2.el6.noarch
--> Processing Dependency: facter >= 1.5 for package: puppet-2.7.26-2.el6.noarch
--> Processing Dependency: ruby-shadow for package: puppet-2.7.26-2.el6.noarch
--> Processing Dependency: ruby-augeas for package: puppet-2.7.26-2.el6.noarch
--> Processing Dependency: ruby(selinux) for package: puppet-2.7.26-2.el6.noarch
--> Processing Dependency: /usr/bin/ruby for package: puppet-2.7.26-2.el6.noarch
---> Package python-gofer.noarch 0:2.6.6-2.el6 will be installed
---> Package python-gofer-qpid.noarch 0:2.6.6-2.el6 will be installed
--> Processing Dependency: python-qpid >= 0.18 for package: python-gofer-qpid-2.6.6-2.el6.noarch
---> Package python-pulp-agent-lib.noarch 0:2.8.0-0.5.beta.git.107.d52583d.el6 will be installed
---> Package python-pulp-bindings.noarch 0:2.8.0-0.5.beta.git.107.d52583d.el6 will be installed
--> Processing Dependency: python-oauth2 >= 1.5.170-2.pulp for package: python-pulp-bindings-2.8.0-0.5.beta.git.107.d52583d.el6.noarch
---> Package python-pulp-client-lib.noarch 0:2.8.0-0.5.beta.git.107.d52583d.el6 will be installed
--> Processing Dependency: python-okaara >= 1.0.32 for package: python-pulp-client-lib-2.8.0-0.5.beta.git.107.d52583d.el6.noarch
--> Processing Dependency: python-isodate >= 0.5.0-1.pulp for package: python-pulp-client-lib-2.8.0-0.5.beta.git.107.d52583d.el6.noarch
---> Package python-pulp-common.noarch 0:2.8.0-0.5.beta.git.107.d52583d.el6 will be installed
---> Package python-pulp-puppet-common.noarch 0:2.8.0-0.5.beta.git.6.5894bd0.el6 will be installed
---> Package python-pulp-rpm-common.noarch 0:2.8.0-0.5.beta.git.46.c9f2464.el6 will be installed
--> Running transaction check
---> Package facter.x86_64 0:1.6.18-8.el6 will be installed
---> Package libselinux-ruby.x86_64 0:2.0.94-5.8.el6 will be installed
---> Package python-gofer-qpid.noarch 0:2.6.6-2.el6 will be installed
--> Processing Dependency: python-qpid >= 0.18 for package: python-gofer-qpid-2.6.6-2.el6.noarch
---> Package python-isodate.noarch 0:0.5.0-4.pulp.el6 will be installed
---> Package python-oauth2.noarch 0:1.5.211-8.el6 will be installed
--> Processing Dependency: python-simplejson for package: python-oauth2-1.5.211-8.el6.noarch
--> Processing Dependency: python-httplib2 for package: python-oauth2-1.5.211-8.el6.noarch
---> Package python-okaara.noarch 0:1.0.35-1.el6 will be installed
---> Package ruby.x86_64 0:1.8.7.374-4.el6_6 will be installed
---> Package ruby-augeas.x86_64 0:0.4.1-1.el6 will be installed
---> Package ruby-libs.x86_64 0:1.8.7.374-4.el6_6 will be installed
--> Processing Dependency: libreadline.so.5()(64bit) for package: ruby-libs-1.8.7.374-4.el6_6.x86_64
---> Package ruby-shadow.x86_64 0:1.4.1-13.el6 will be installed
--> Running transaction check
---> Package compat-readline5.x86_64 0:5.2-17.1.el6 will be installed
---> Package python-gofer-qpid.noarch 0:2.6.6-2.el6 will be installed
--> Processing Dependency: python-qpid >= 0.18 for package: python-gofer-qpid-2.6.6-2.el6.noarch
---> Package python-httplib2.noarch 0:0.7.7-1.el6 will be installed
---> Package python-simplejson.x86_64 0:2.0.9-3.1.el6 will be installed
--> Finished Dependency Resolution
Error: Package: python-gofer-qpid-2.6.6-2.el6.noarch (pulp-2.7-beta)
           Requires: python-qpid >= 0.18
           Available: python-qpid-0.14-11.el6_3.noarch (beaker-Server)
               python-qpid = 0.14-11.el6_3
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest

History

#1 Updated by dkliban@redhat.com over 4 years ago

I believe this issue can be resolved by enabling the qpid copr repo. More info can be found here[0]

[0] http://qpid.apache.org/packages.html#epel

#2 Updated by pthomas@redhat.com over 4 years ago

please update the documentation.

#3 Updated by mhrivnak over 4 years ago

  • Status changed from NEW to CLOSED - NOTABUG

Preethi says this is not a bug.

#4 Updated by bmbouter over 1 year ago

  • Tags Pulp 2 added

Please register to edit this issue

Also available in: Atom PDF