Project

Profile

Help

Issue #1680

Cosumer install on El5 fails with dep issues

Added by pthomas@redhat.com over 4 years ago. Updated over 1 year ago.

Status:
CLOSED - CURRENTRELEASE
Priority:
Normal
Category:
-
Start date:
Due date:
Estimated time:
Severity:
2. Medium
Version:
Platform Release:
2.8.0
OS:
Triaged:
Yes
Groomed:
No
Sprint Candidate:
No
Tags:
Pulp 2
Sprint:
Quarter:

Description

pulp consumer install on rhel5 seems to be failing

[root@beast ~]#  sudo yum groupinstall pulp-consumer-qpid
Loaded plugins: product-id, rhnplugin, security, subscription-manager
This system is not registered to Red Hat Subscription Management. You can use subscription-manager to register.
This system is receiving updates from RHN Classic or RHN Satellite.
pulp-2.8-beta                                            | 3.0 kB     00:00    
pulp-2.8-beta/primary_db                                 |  10 kB     00:00    
Setting up Group Process
pulp-2.8-beta/group_gz                                   |  536 B     00:00    
Resolving Dependencies
--> Running transaction check
---> Package pulp-agent.noarch 0:2.8.0-0.5.beta.git.107.d52583d.el5 set to be updated
--> Processing Dependency: python-pulp-bindings = 2.8.0 for package: pulp-agent
--> Processing Dependency: python-pulp-agent-lib = 2.8.0 for package: pulp-agent
--> Processing Dependency: python-gofer >= 2.5 for package: pulp-agent
--> Processing Dependency: gofer >= 2.5 for package: pulp-agent
---> Package pulp-consumer-client.noarch 0:2.8.0-0.5.beta.git.107.d52583d.el5 set to be updated
--> Processing Dependency: python-pulp-common = 2.8.0 for package: pulp-consumer-client
--> Processing Dependency: python-pulp-client-lib = 2.8.0 for package: pulp-consumer-client
---> Package pulp-puppet-consumer-extensions.noarch 0:2.8.0-0.5.beta.git.6.5894bd0.el5 set to be updated
--> Processing Dependency: python-pulp-puppet-common = 2.8.0 for package: pulp-puppet-consumer-extensions
---> Package pulp-puppet-handlers.noarch 0:2.8.0-0.5.beta.git.6.5894bd0.el5 set to be updated
--> Processing Dependency: puppet >= 2.7.14 for package: pulp-puppet-handlers
---> Package pulp-rpm-consumer-extensions.noarch 0:2.8.0-0.5.beta.git.46.c9f2464.el5 set to be updated
---> Package pulp-rpm-handlers.noarch 0:2.8.0-0.5.beta.git.46.c9f2464.el5 set to be updated
--> Processing Dependency: python-pulp-rpm-common = 2.8.0 for package: pulp-rpm-handlers
---> Package pulp-rpm-yumplugins.noarch 0:2.8.0-0.5.beta.git.46.c9f2464.el5 set to be updated
---> Package python-gofer-qpid.noarch 0:2.6.6-2.el5 set to be updated
--> Processing Dependency: python-qpid >= 0.18 for package: python-gofer-qpid
--> Processing Dependency: python-ssl for package: python-gofer-qpid
--> Running transaction check
---> Package gofer.noarch 0:2.6.6-2.el5 set to be updated
---> Package pulp-puppet-handlers.noarch 0:2.8.0-0.5.beta.git.6.5894bd0.el5 set to be updated
--> Processing Dependency: puppet >= 2.7.14 for package: pulp-puppet-handlers
---> Package python-gofer.noarch 0:2.6.6-2.el5 set to be updated
--> Processing Dependency: python-hashlib for package: python-gofer
--> Processing Dependency: python-ctypes for package: python-gofer
---> Package python-gofer-qpid.noarch 0:2.6.6-2.el5 set to be updated
--> Processing Dependency: python-ssl for package: python-gofer-qpid
---> Package python-pulp-agent-lib.noarch 0:2.8.0-0.5.beta.git.107.d52583d.el5 set to be updated
---> Package python-pulp-bindings.noarch 0:2.8.0-0.5.beta.git.107.d52583d.el5 set to be updated
---> Package python-pulp-client-lib.noarch 0:2.8.0-0.5.beta.git.107.d52583d.el5 set to be updated
--> Processing Dependency: python-okaara >= 1.0.32 for package: python-pulp-client-lib
--> Processing Dependency: python-isodate >= 0.5.0-1.pulp for package: python-pulp-client-lib
---> Package python-pulp-common.noarch 0:2.8.0-0.5.beta.git.107.d52583d.el5 set to be updated
--> Processing Dependency: python-isodate >= 0.5.0-1.pulp for package: python-pulp-common
---> Package python-pulp-puppet-common.noarch 0:2.8.0-0.5.beta.git.6.5894bd0.el5 set to be updated
---> Package python-pulp-rpm-common.noarch 0:2.8.0-0.5.beta.git.46.c9f2464.el5 set to be updated
---> Package python-qpid.noarch 0:0.18-10.el5 set to be updated
--> Processing Dependency: python-saslwrapper >= 0.10 for package: python-qpid
--> Running transaction check
---> Package pulp-puppet-handlers.noarch 0:2.8.0-0.5.beta.git.6.5894bd0.el5 set to be updated
--> Processing Dependency: puppet >= 2.7.14 for package: pulp-puppet-handlers
---> Package python-ctypes.x86_64 0:1.0.2-3.el5 set to be updated
---> Package python-gofer-qpid.noarch 0:2.6.6-2.el5 set to be updated
--> Processing Dependency: python-ssl for package: python-gofer-qpid
---> Package python-hashlib.x86_64 0:20081119-4.el5 set to be updated
---> Package python-pulp-client-lib.noarch 0:2.8.0-0.5.beta.git.107.d52583d.el5 set to be updated
--> Processing Dependency: python-okaara >= 1.0.32 for package: python-pulp-client-lib
--> Processing Dependency: python-isodate >= 0.5.0-1.pulp for package: python-pulp-client-lib
---> Package python-pulp-common.noarch 0:2.8.0-0.5.beta.git.107.d52583d.el5 set to be updated
--> Processing Dependency: python-isodate >= 0.5.0-1.pulp for package: python-pulp-common
---> Package python-saslwrapper.x86_64 0:0.10-8.el5 set to be updated
--> Processing Dependency: saslwrapper = 0.10-8.el5 for package: python-saslwrapper
--> Processing Dependency: libsaslwrapper.so.1()(64bit) for package: python-saslwrapper
--> Running transaction check
---> Package pulp-puppet-handlers.noarch 0:2.8.0-0.5.beta.git.6.5894bd0.el5 set to be updated
--> Processing Dependency: puppet >= 2.7.14 for package: pulp-puppet-handlers
---> Package python-gofer-qpid.noarch 0:2.6.6-2.el5 set to be updated
--> Processing Dependency: python-ssl for package: python-gofer-qpid
---> Package python-pulp-client-lib.noarch 0:2.8.0-0.5.beta.git.107.d52583d.el5 set to be updated
--> Processing Dependency: python-okaara >= 1.0.32 for package: python-pulp-client-lib
--> Processing Dependency: python-isodate >= 0.5.0-1.pulp for package: python-pulp-client-lib
---> Package python-pulp-common.noarch 0:2.8.0-0.5.beta.git.107.d52583d.el5 set to be updated
--> Processing Dependency: python-isodate >= 0.5.0-1.pulp for package: python-pulp-common
---> Package saslwrapper.x86_64 0:0.10-8.el5 set to be updated
--> Finished Dependency Resolution
python-pulp-common-2.8.0-0.5.beta.git.107.d52583d.el5.noarch from pulp-2.8-beta has depsolving problems
  --> Missing Dependency: python-isodate >= 0.5.0-1.pulp is needed by package python-pulp-common-2.8.0-0.5.beta.git.107.d52583d.el5.noarch (pulp-2.8-beta)
python-pulp-client-lib-2.8.0-0.5.beta.git.107.d52583d.el5.noarch from pulp-2.8-beta has depsolving problems
  --> Missing Dependency: python-okaara >= 1.0.32 is needed by package python-pulp-client-lib-2.8.0-0.5.beta.git.107.d52583d.el5.noarch (pulp-2.8-beta)
python-gofer-qpid-2.6.6-2.el5.noarch from pulp-2.8-beta has depsolving problems
  --> Missing Dependency: python-ssl is needed by package python-gofer-qpid-2.6.6-2.el5.noarch (pulp-2.8-beta)
python-pulp-client-lib-2.8.0-0.5.beta.git.107.d52583d.el5.noarch from pulp-2.8-beta has depsolving problems
  --> Missing Dependency: python-isodate >= 0.5.0-1.pulp is needed by package python-pulp-client-lib-2.8.0-0.5.beta.git.107.d52583d.el5.noarch (pulp-2.8-beta)
pulp-puppet-handlers-2.8.0-0.5.beta.git.6.5894bd0.el5.noarch from pulp-2.8-beta has depsolving problems
  --> Missing Dependency: puppet >= 2.7.14 is needed by package pulp-puppet-handlers-2.8.0-0.5.beta.git.6.5894bd0.el5.noarch (pulp-2.8-beta)
Error: Missing Dependency: python-ssl is needed by package python-gofer-qpid-2.6.6-2.el5.noarch (pulp-2.8-beta)
Error: Missing Dependency: python-okaara >= 1.0.32 is needed by package python-pulp-client-lib-2.8.0-0.5.beta.git.107.d52583d.el5.noarch (pulp-2.8-beta)
Error: Missing Dependency: puppet >= 2.7.14 is needed by package pulp-puppet-handlers-2.8.0-0.5.beta.git.6.5894bd0.el5.noarch (pulp-2.8-beta)
Error: Missing Dependency: python-isodate >= 0.5.0-1.pulp is needed by package python-pulp-common-2.8.0-0.5.beta.git.107.d52583d.el5.noarch (pulp-2.8-beta)
Error: Missing Dependency: python-isodate >= 0.5.0-1.pulp is needed by package python-pulp-client-lib-2.8.0-0.5.beta.git.107.d52583d.el5.noarch (pulp-2.8-beta)
 You could try using --skip-broken to work around the problem
 You could try running: package-cleanup --problems
                        package-cleanup --dupes
                        rpm -Va --nofiles --nodigest

History

#1 Updated by dkliban@redhat.com over 4 years ago

I believe part of the problem is that EPEL repository is not enabled on this machine. The other problem is that we are not providing python-isodate in our el5 repository. Can you please enable EPEL and try again. You should see only python-isodate missing at that point.

#2 Updated by dkliban@redhat.com over 4 years ago

  • Status changed from NEW to ASSIGNED
  • Assignee set to dkliban@redhat.com

#3 Updated by pthomas@redhat.com over 4 years ago

Enabled epel and now only python-isodate is missing.

#4 Updated by mhrivnak over 4 years ago

  • Project changed from Packaging to Pulp
  • Status changed from ASSIGNED to MODIFIED
  • Triaged changed from No to Yes

#5 Updated by dkliban@redhat.com over 4 years ago

  • Platform Release set to 2.8.0

#6 Updated by dkliban@redhat.com over 4 years ago

  • Status changed from MODIFIED to 5

#7 Updated by dkliban@redhat.com over 4 years ago

  • Status changed from 5 to CLOSED - CURRENTRELEASE

#8 Updated by bmbouter over 1 year ago

  • Tags Pulp 2 added

Please register to edit this issue

Also available in: Atom PDF