Project

Profile

Help

Issue #1491

Cannot create a repository schedule via api

Added by paji@redhat.com almost 6 years ago. Updated over 2 years ago.

Status:
CLOSED - DUPLICATE
Priority:
High
Assignee:
-
Category:
-
Sprint/Milestone:
-
Start date:
Due date:
Estimated time:
Severity:
3. High
Version:
Master
Platform Release:
OS:
Triaged:
Yes
Groomed:
No
Sprint Candidate:
No
Tags:
Pulp 2
Sprint:
Quarter:

Description

1) Create an rpm repo

RestClient.post "https://katello-pulp-nightly.example.com/pulp/api/v2/repositories/", "{\"id\":\"integration_test_id\",\"importer_type_id\":\"yum_importer\",\"importer_config\":{\"feed\":\"file:///var/www/repositories/zoo5\"}}"

2) Create a schedule

 RestClient.post "https://katello-pulp-nightly.example.com/pulp/api/v2/repositories/integration_test_id/importers/yum_importer/schedules/sync/", {"schedule":"2012-09-25T20:44:00Z/P7D"},{"content_type"=>"application/json", "accept"=>"application/json"}

Expected : Schedule created
Actual : ISE

pulp.server.webservices.middleware.exception:ERROR: Unhandled Exception
pulp.server.webservices.middleware.exception:ERROR: (2742-54208) Cannot encode object: <User: User object>
pulp.server.webservices.middleware.exception:ERROR: (2742-54208) Traceback (most recent call last):
pulp.server.webservices.middleware.exception:ERROR: (2742-54208)   File "/usr/lib/python2.7/site-packages/django/core/handlers/base.py", line 112, 

pulp.server.webservices.middleware.exception:ERROR: (2742-54208)     response = wrapped_callback(request, *callback_args, **callback_kwargs)
pulp.server.webservices.middleware.exception:ERROR: (2742-54208)   File "/usr/lib/python2.7/site-packages/django/views/generic/base.py", line 69, i

pulp.server.webservices.middleware.exception:ERROR: (2742-54208)     return self.dispatch(request, *args, **kwargs)
pulp.server.webservices.middleware.exception:ERROR: (2742-54208)   File "/usr/lib/python2.7/site-packages/django/views/generic/base.py", line 87, i

pulp.server.webservices.middleware.exception:ERROR: (2742-54208)     return handler(request, *args, **kwargs)
pulp.server.webservices.middleware.exception:ERROR: (2742-54208)   File "/usr/lib/python2.7/site-packages/pulp/server/webservices/views/decorators.

pulp.server.webservices.middleware.exception:ERROR: (2742-54208)     return _verify_auth(self, operation, super_user_only, method, *args, **kwargs)
pulp.server.webservices.middleware.exception:ERROR: (2742-54208)   File "/usr/lib/python2.7/site-packages/pulp/server/webservices/views/decorators.

pulp.server.webservices.middleware.exception:ERROR: (2742-54208)     value = method(self, *args, **kwargs)
pulp.server.webservices.middleware.exception:ERROR: (2742-54208)   File "/usr/lib/python2.7/site-packages/pulp/server/webservices/views/util.py", l

pulp.server.webservices.middleware.exception:ERROR: (2742-54208)     return func(*args, **kwargs)
pulp.server.webservices.middleware.exception:ERROR: (2742-54208)   File "/usr/lib/python2.7/site-packages/pulp/server/webservices/views/repositorie

pulp.server.webservices.middleware.exception:ERROR: (2742-54208)     schedule, failure_threshold, enabled)
pulp.server.webservices.middleware.exception:ERROR: (2742-54208)   File "/usr/lib/python2.7/site-packages/pulp/server/managers/schedule/repo.py", l

pulp.server.webservices.middleware.exception:ERROR: (2742-54208)     schedule.save()
pulp.server.webservices.middleware.exception:ERROR: (2742-54208)   File "/usr/lib/python2.7/site-packages/pulp/server/db/model/dispatch.py", line 2

pulp.server.webservices.middleware.exception:ERROR: (2742-54208)     self.get_collection().insert(as_dict)
pulp.server.webservices.middleware.exception:ERROR: (2742-54208)   File "/usr/lib64/python2.7/site-packages/pymongo/collection.py", line 409, in in

pulp.server.webservices.middleware.exception:ERROR: (2742-54208)     gen(), check_keys, self.uuid_subtype, client)
pulp.server.webservices.middleware.exception:ERROR: (2742-54208) InvalidDocument: Cannot encode object: <User: User object>
nt[655]: DHCPREQUEST on eth0 to 192.168.121.1 port 67 (xid=0x4e414be3)

Related issues

Is duplicate of Pulp - Issue #1381: HTTP 500 when attempting to create a sync scheduleCLOSED - CURRENTRELEASE<a title="Actions" class="icon-only icon-actions js-contextmenu" href="#">Actions</a>

History

#1 Updated by mhrivnak almost 6 years ago

  • Priority changed from Normal to High
  • Severity changed from 2. Medium to 3. High
  • Platform Release set to 2.8.0
  • Triaged changed from No to Yes

#2 Updated by mhrivnak almost 6 years ago

  • Is duplicate of Issue #1381: HTTP 500 when attempting to create a sync schedule added

#3 Updated by mhrivnak almost 6 years ago

  • Status changed from NEW to CLOSED - DUPLICATE
  • Platform Release deleted (2.8.0)

#4 Updated by bmbouter over 2 years ago

  • Tags Pulp 2 added

Please register to edit this issue

Also available in: Atom PDF