Project

Profile

Help

Issue #1462

closed

Errata Install to Content Host takes too long and doesn't scale well

Added by mhrivnak about 7 years ago. Updated almost 4 years ago.

Status:
CLOSED - CURRENTRELEASE
Priority:
High
Sprint/Milestone:
-
Start date:
Due date:
Estimated time:
Severity:
2. Medium
Version:
2.6.0
Platform Release:
2.8.5
OS:
Triaged:
Yes
Groomed:
No
Sprint Candidate:
No
Tags:
Pulp 2
Sprint:
Sprint 2
Quarter:

Description

We have a report that installing a number of erratta takes a long time. There is no info about what the bottleneck is, so we need to investigate.

From bugzilla:


When applying (installing) errata on a Content Host from the server, it takes a very long time.

For example, installing ~556 errata on a single content host was observed to take ~44 minutes. Most of that time (~36 minutes) was during the 'initiating the install' phase of the task (i.e. executing the pulp consumer content install).  While this may not sound too bad a first glance, it won't scale well as the behavior is linear.  As a result, if there were 100 content hosts, that same action could take ~3 days.
Actions #1

Updated by mhrivnak about 7 years ago

  • Platform Release set to 2.8.0
  • Triaged changed from No to Yes
Actions #2

Updated by mhrivnak about 7 years ago

  • Priority changed from High to Normal
Actions #3

Updated by jortel@redhat.com about 7 years ago

  • Priority changed from Normal to High
  • Platform Release changed from 2.8.0 to 2.8.1
Actions #4

Updated by dkliban@redhat.com almost 7 years ago

  • Status changed from NEW to ASSIGNED
  • Assignee set to dkliban@redhat.com
Actions #5

Updated by semyers almost 7 years ago

  • Platform Release changed from 2.8.1 to 2.8.2
Actions #6

Updated by mhrivnak almost 7 years ago

  • Sprint/Milestone set to 19
Actions #7

Updated by semyers almost 7 years ago

  • Platform Release changed from 2.8.2 to 2.8.3
Actions #9

Updated by semyers almost 7 years ago

  • Platform Release changed from 2.8.3 to 2.8.4
Actions #10

Updated by dkliban@redhat.com almost 7 years ago

The problem stems from the fact that Pulp takes each errata and turns it into a list of packages. As the number of errata grows, the amount of time it takes to translate them into package lists grows.

The proper solution is to smarten up the Katello agent/pulpplugin for Gofer to be aware of errata as a content type. This way Pulp can completely avoid having to generate lists of packages. Yum is very good at figuring out what packages belong to what errata.

I have tested this solution with yum 3.4.3 on RHEL7.

I have also tested this with yum 3.2.22 and yum-security 1.1.16 on RHEL 5.10.

I have confirmed that Yum 3.2.22 ans yum-security 1.1.16 have shipped with RHEL 5 since update 5.

Actions #11

Updated by mhrivnak almost 7 years ago

  • Sprint/Milestone changed from 19 to 20
Actions #12

Updated by dkliban@redhat.com over 6 years ago

  • Status changed from ASSIGNED to POST

Added by dkliban@redhat.com over 6 years ago

Revision 5b1434ba

Improves performance of errata installation.

Pulp API no longer translates errata into a list of packages applicable to a consumer. Errata ids are passed to the agent on the consumer where yum and security plugin take care of the translation. The new functionality is equivalent to running

yum update-minimal --advisories=<errata_id>,<another_id>

on the consumer.

closes #1462 https://pulp.plan.io/issues/1462

Actions #13

Updated by dkliban@redhat.com over 6 years ago

  • Status changed from POST to MODIFIED
  • % Done changed from 0 to 100
Actions #14

Updated by semyers over 6 years ago

  • Status changed from MODIFIED to 5
Actions #15

Updated by semyers over 6 years ago

  • Platform Release changed from 2.8.4 to 2.8.5
Actions #16

Updated by semyers over 6 years ago

  • Status changed from 5 to MODIFIED
Actions #18

Updated by semyers over 6 years ago

  • Status changed from MODIFIED to 5
Actions #19

Updated by semyers over 6 years ago

  • Status changed from 5 to CLOSED - CURRENTRELEASE
Actions #21

Updated by bmbouter almost 5 years ago

  • Sprint set to Sprint 2
Actions #22

Updated by bmbouter almost 5 years ago

  • Sprint/Milestone deleted (20)
Actions #23

Updated by bmbouter almost 4 years ago

  • Tags Pulp 2 added

Also available in: Atom PDF