Project

Profile

Help

Issue #1428

publish of distributions has has exception regarding folder creation

Added by bmbouter about 5 years ago. Updated almost 2 years ago.

Status:
CLOSED - WORKSFORME
Priority:
High
Assignee:
Sprint/Milestone:
-
Start date:
Due date:
Estimated time:
Severity:
2. Medium
Version:
Platform Release:
2.8.0
OS:
Triaged:
Yes
Groomed:
No
Sprint Candidate:
No
Tags:
Pulp 2
Sprint:
Quarter:

Description

1. sync a a repo with a distribution in it
2. delete that distribution
3. re-sync the distribution from (1)
4. Observe that there will be an exception regarding folder creation

History

#1 Updated by mhrivnak about 5 years ago

  • Triaged changed from No to Yes

#2 Updated by bmbouter about 5 years ago

  • Status changed from NEW to ASSIGNED
  • Assignee set to bmbouter

#3 Updated by bmbouter about 5 years ago

I've been trying to reproduce this, but I haven't been able to. Here is my attempt at a reproducer script:

pulp-admin login -u admin -p admin

pulp-admin rpm repo delete --repo-id rawhide

pulp-admin rpm repo create --repo-id rawhide --feed http://dl.fedoraproject.org/pub/fedora/linux/development/rawhide/x86_64/os/ --skip=rpm,drpm,erratum

pulp-admin rpm repo sync run --repo-id rawhide

pulp-admin orphan list # verify 0 orphans

pulp-admin rpm repo remove distribution --repo-id rawhide --str-eq="family=Fedora"

pulp-admin orphan list # verify 1 orphan of type distribution

pulp-admin orphan remove --all

pulp-admin orphan list # verify 0 orphans

pulp-admin rpm repo sync run --repo-id rawhide

All tasks complete and a manual inspection of the published data looks good correct also.

#4 Updated by mhrivnak about 5 years ago

I can't reproduce anymore. I assume it got fixed by some other recent change. I suggest closing.

#5 Updated by bmbouter about 5 years ago

  • Status changed from ASSIGNED to CLOSED - WORKSFORME

#6 Updated by bmbouter almost 2 years ago

  • Tags Pulp 2 added

Please register to edit this issue

Also available in: Atom PDF