Project

Profile

Help

Issue #1387

can't sync graphviz repo for el7

Added by cristi.falcas@gmail.com about 6 years ago. Updated almost 3 years ago.

Status:
CLOSED - WORKSFORME
Priority:
Normal
Assignee:
-
Category:
-
Sprint/Milestone:
-
Start date:
Due date:
Estimated time:
Severity:
2. Medium
Version:
2.7.0
Platform Release:
OS:
Triaged:
Yes
Groomed:
No
Sprint Candidate:
No
Tags:
Pulp 2
Sprint:
Quarter:

Description

When trying to sync the el7 graphviz repo (http://www.graphviz.org/pub/graphviz/stable/redhat/el7/x86_64/os/) we get the following error:

  1. pulp-admin -v rpm repo sync run --repo-id graphviz_el7
    ----------------------------------------------------------------------
    Synchronizing Repository [graphviz_el7]
    --------------------------------------------------------------------

This command may be exited via ctrl+c without affecting the request.

Downloading metadata...
[|]
... completed

Downloading repository content...
[==================================================] 100%
RPMs: 7/7 items
Delta RPMs: 0/0 items

... completed

Individual package errors encountered during sync:

2015-11-25 04:04:35,751 - ERROR - Client-side exception occurred
Traceback (most recent call last):
File "/usr/lib/python2.7/site-packages/pulp/client/extensions/core.py", line 474, in run
exit_code = Cli.run(self, args)
File "/usr/lib/python2.7/site-packages/okaara/cli.py", line 974, in run
exit_code = command_or_section.execute(self.prompt, remaining_args)
File "/usr/lib/python2.7/site-packages/pulp/client/extensions/extensions.py", line 210, in execute
return self.method(*arg_list, **clean_kwargs)
File "/usr/lib/python2.7/site-packages/pulp/client/commands/repo/sync_publish.py", line 127, in run
self.poll([sync_task], kwargs)
File "/usr/lib/python2.7/site-packages/pulp/client/commands/polling.py", line 120, in poll
task = self._poll_task(task)
File "/usr/lib/python2.7/site-packages/pulp/client/commands/polling.py", line 211, in _poll_task
self.progress(task, running_spinner)
File "/usr/lib/python2.7/site-packages/pulp/client/commands/repo/sync_publish.py", line 72, in progress
self.renderer.display_report(task.progress_report)
File "/usr/lib/python2.7/site-packages/pulp_rpm/extensions/admin/status.py", line 69, in display_report
self.render_download_step(progress_report)
File "/usr/lib/python2.7/site-packages/pulp_rpm/extensions/admin/status.py", line 256, in render_download_step
'name': error[constants.NAME],
KeyError: 'name'
An unexpected error has occurred. More information may be found using the -v
flag.

History

#1 Updated by ipanova@redhat.com about 6 years ago

I was not able to reproduce the issue.

$ pulp-admin rpm repo create --repo-id test-repo --feed http://www.graphviz.org/pub/graphviz/stable/redhat/el7/x86_64/os/

Successfully created repository [test-repo]
$ pulp-admin -v rpm repo sync run --repo-id test-repo 

+----------------------------------------------------------------------+
                  Synchronizing Repository [test-repo]
+----------------------------------------------------------------------+

This command may be exited via ctrl+c without affecting the request.

Downloading metadata...
[|]
... completed

Downloading repository content...
[==================================================] 100%
RPMs:       28/28 items
Delta RPMs: 0/0 items

... completed

Downloading distribution files...
[==================================================] 100%
Distributions: 0/0 items
... completed

Importing errata...
[-]
... completed

Importing package groups/categories...
[-]
... completed

Task Succeeded

Initializing repo metadata
[-]
... completed

Publishing Distribution files
[-]
... completed

Publishing RPMs
[==================================================] 100%
28 of 28 items
... completed

Publishing Delta RPMs
... skipped

Publishing Errata
[-]
... completed

Publishing Comps file
[-]
... completed

Publishing Metadata.
[-]
... completed

Closing repo metadata
[-]
... completed

Generating sqlite files
... skipped

Publishing files to web
[-]
... completed

Writing Listings File
[-]
... completed

Task Succeeded

#2 Updated by jortel@redhat.com about 6 years ago

  • Status changed from NEW to CLOSED - WORKSFORME
  • Triaged changed from No to Yes

Cannot reproduce. Please reopen if you see this again.

#3 Updated by bmbouter almost 3 years ago

  • Tags Pulp 2 added

Also available in: Atom PDF