Project

Profile

Help

Issue #1341

qpid-cpp-server-store not available in rhel 7 anymore

Added by placko almost 6 years ago. Updated over 1 year ago.

Status:
CLOSED - CURRENTRELEASE
Priority:
High
Assignee:
Category:
-
Sprint/Milestone:
-
Start date:
Due date:
Estimated time:
Severity:
2. Medium
Version:
2.7.0 Beta
Platform Release:
2.7.2
OS:
RHEL 7
Triaged:
Yes
Groomed:
No
Sprint Candidate:
No
Tags:
Documentation, Easy Fix, Pulp 2
Sprint:
Quarter:

Description

According to installation guide [1], users should install qpid-cpp-server-store and if possible install qpid-cpp-server-linearstore instead. qpid-cpp-server-store is however not present in repositories anymore.

http://pulp.readthedocs.org/en/latest/user-guide/installation.html

Associated revisions

Revision c4d113c3 View on GitHub
Added by semyers almost 6 years ago

docs no longer mention qpid-cpp-store

qpid-cpp-linearstore is available in all supported distributions now (woot), so we can remove the note about how you might want to install it instead of the -store package in favor of installing the -linearstore package everywhere.

There are also some minor docs fixes:

  • Indentations fixed so autonumbering works correctly in the 'Server' installation steps
  • Added subsections to the Repositories section of the install guide, and made the brokers subsection call out that the guide expects qpid to be installed

https://pulp.plan.io/issues/1341

fixes #1341

https://pulp.plan.io/issues/842

refs #842

Revision c4d113c3 View on GitHub
Added by semyers almost 6 years ago

docs no longer mention qpid-cpp-store

qpid-cpp-linearstore is available in all supported distributions now (woot), so we can remove the note about how you might want to install it instead of the -store package in favor of installing the -linearstore package everywhere.

There are also some minor docs fixes:

  • Indentations fixed so autonumbering works correctly in the 'Server' installation steps
  • Added subsections to the Repositories section of the install guide, and made the brokers subsection call out that the guide expects qpid to be installed

https://pulp.plan.io/issues/1341

fixes #1341

https://pulp.plan.io/issues/842

refs #842

History

#1 Updated by bmbouter almost 6 years ago

We should revise the documentation to recommend only qpid-cpp-server-linearstore. We should no longer recommend qpid-cpp-server-store at all. I confirmed with the qpid team that since we'll be using qpid-server 0.34, we should never use qpid-cpp-server-store.

#2 Updated by mhrivnak almost 6 years ago

  • Priority changed from Normal to High
  • Severity changed from 1. Low to 2. Medium
  • Triaged changed from No to Yes
  • Tags Easy Fix added

#3 Updated by semyers almost 6 years ago

  • Status changed from NEW to ASSIGNED
  • Assignee set to semyers

#4 Updated by bmbouter almost 6 years ago

I'm confirming this change is safe for EL6, EL7, and all the fedoras.

#5 Updated by semyers almost 6 years ago

  • Status changed from ASSIGNED to POST

#6 Updated by semyers almost 6 years ago

There is a tiny bit of funkiness for el7, which is that qpidd currently doesn't work when you get it from EPEL[0], but that's not technically pulp's problem...

The solution is already being tested for release into EPEL[1], but needs some karmic love to make it to stable. The working qpid packages are ready for testing in the epel-testing repo, and I'll stay on top of them to encourage their going into epel stable in favor of packages that are completely broken.

[0]: https://bugzilla.redhat.com/show_bug.cgi?id=1280372
[1]: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2015-40795af09d

#8 Updated by semyers almost 6 years ago

  • Status changed from POST to MODIFIED
  • % Done changed from 0 to 100

#9 Updated by semyers almost 6 years ago

  • Platform Release set to 2.7.2

#10 Updated by dkliban@redhat.com over 5 years ago

  • Status changed from MODIFIED to 5

#11 Updated by semyers over 5 years ago

  • Status changed from 5 to CLOSED - CURRENTRELEASE

#12 Updated by bmbouter over 2 years ago

  • Tags Pulp 2 added

#13 Updated by bmbouter over 1 year ago

  • Category deleted (23)

Please register to edit this issue

Also available in: Atom PDF