Project

Profile

Help

Issue #1214

closed

Duplicate entry in PULP_MANIFEST causes traceback on puppet directory importer

Added by bmbouter over 6 years ago. Updated about 3 years ago.

Status:
CLOSED - WONTFIX
Priority:
Normal
Assignee:
-
Start date:
Due date:
Estimated time:
Severity:
1. Low
Version:
Platform Release:
OS:
Triaged:
Yes
Groomed:
No
Sprint Candidate:
No
Tags:
Pulp 2
Sprint:
Quarter:

Description

To reproduce:

1. Follow the xinetd module builder
2. Edit the PULP_MANIFEST to copy the first line to the second line
3. Run the following Pulp commands:

pulp-admin login -u admin -p admin
pulp-admin puppet repo create --repo-id=acme --feed=file:///opt/puppet/modules/
pulp-admin puppet repo sync run --repo-id acme

You'll see this traceback in the logs and the CLI will error:

 Traceback (most recent call last):
   File "/usr/lib/python2.7/site-packages/celery-3.1.11-py2.7.egg/celery/app/trace.py", line 240, in trace_task
     R = retval = fun(*args, **kwargs)
   File "/home/bmbouter/Documents/pulp/server/pulp/server/async/tasks.py", line 393, in __call__ 
     return super(Task, self).__call__(*args, **kwargs)
   File "/usr/lib/python2.7/site-packages/celery-3.1.11-py2.7.egg/celery/app/trace.py", line 437, in __protected_call__
     return self.run(*args, **kwargs)
   File "/home/bmbouter/Documents/pulp/server/pulp/server/controllers/repository.py", line 555, in sync
     sync_report = sync_repo(transfer_repo, conduit, call_config)
   File "/home/bmbouter/Documents/pulp/server/pulp/server/async/tasks.py", line 558, in wrap_f   
     return f(*args, **kwargs)
   File "/home/bmbouter/Documents/pulp_puppet/pulp_puppet_plugins/pulp_puppet/plugins/importers/importer.py", line 65, in sync_repo
     report = self.sync_method()
   File "/home/bmbouter/Documents/pulp_puppet/pulp_puppet_plugins/pulp_puppet/plugins/importers/directory.py", line 317, in __call__
     self._import_modules(module_paths)
   File "/home/bmbouter/Documents/pulp_puppet/pulp_puppet_plugins/pulp_puppet/plugins/importers/directory.py", line 265, in _import_modules
     module.save()
   File "/usr/lib/python2.7/site-packages/mongoengine/document.py", line 359, in save
     raise NotUniqueError(message % unicode(err))
 NotUniqueError: Tried to save duplicate unique keys (insertDocument :: caused by :: 11000 E11000 duplicate key error index: pulp_database.units_puppet_module.$name_1_version_1_author_1  dup key: { : "puppetlabs-xinetd", : "1.5.0", : "puppetlabs" })
Actions #1

Updated by mhrivnak over 6 years ago

  • Severity changed from 2. Medium to 1. Low
  • Triaged changed from No to Yes
Actions #2

Updated by bmbouter about 3 years ago

  • Status changed from NEW to CLOSED - WONTFIX

Pulp 2 is approaching maintenance mode, and this Pulp 2 ticket is not being actively worked on. As such, it is being closed as WONTFIX. Pulp 2 is still accepting contributions though, so if you want to contribute a fix for this ticket, please reopen or comment on it. If you don't have permissions to reopen this ticket, or you want to discuss an issue, please reach out via the developer mailing list.

Actions #3

Updated by bmbouter about 3 years ago

  • Tags Pulp 2 added

Also available in: Atom PDF