Project

Profile

Help

Issue #117

closed

Validation message for docker repo create does not make sense

Added by pthomas@redhat.com about 8 years ago. Updated almost 4 years ago.

Status:
CLOSED - DUPLICATE
Priority:
Normal
Start date:
Due date:
Estimated time:
Severity:
2. Medium
Version - Docker:
Platform Release:
Target Release - Docker:
OS:
Triaged:
Yes
Groomed:
No
Sprint Candidate:
No
Tags:
Pulp 2
Sprint:
Quarter:

Description

Validation message should be clear when its failing on repo name.

[root@cloud-qe-17 docker]# rpm -qa pulp-server
pulp-server-2.6.0-0.5.beta.el7.noarch
[root@cloud-qe-17 docker]#

1. Create a docker repo wih the --repo-id with a capital letter

See the error message

[root@cloud-qe-17 docker]# pulp-admin docker repo create --repo-id Docker-test
The server indicated one or more values were incorrect. The server provided the
following error message:

Pulp exception occurred: PulpDataException

More information can be found in the client log file ~/.pulp/admin.log.

In rpm here is the message we get

root@cloud-qe-17 docker]# pulp-admin rpm repo create --repo-id Docker-test.test%
Validation failed for argument [--repo-id]: value must contain only letters,
numbers, underscores, periods and hyphens


Related issues

Is duplicate of Pulp - Issue #683: Pulp throws away validation error information from distributorsCLOSED - CURRENTRELEASEamacdona@redhat.comActions
Actions #1

Updated by pthomas@redhat.com about 8 years ago

  • Status changed from NEW to ASSIGNED
  • Assignee set to bmbouter
Actions #2

Updated by pthomas@redhat.com about 8 years ago

  • Status changed from ASSIGNED to POST
Actions #3

Updated by pthomas@redhat.com about 8 years ago

  • Status changed from POST to ASSIGNED
Actions #4

Updated by pthomas@redhat.com about 8 years ago

  • Status changed from ASSIGNED to NEW
  • Assignee deleted (bmbouter)
Actions #5

Updated by skarmark@redhat.com about 8 years ago

  • Status changed from NEW to 5
  • Assignee set to amacdona@redhat.com
  • Triaged changed from No to Yes
Actions #6

Updated by amacdona@redhat.com about 8 years ago

I believe that this issue was fixed by this PR. https://github.com/pulp/pulp/pull/1487

Actions #7

Updated by amacdona@redhat.com about 8 years ago

pulp_docker actually does create a helpful exception, but Pulp throws the message away. Closing and reopening as a pulp bug.

https://bugzilla.redhat.com/show_bug.cgi?id=1187200

Actions #8

Updated by amacdona@redhat.com about 8 years ago

  • Status changed from 5 to 7
Actions #9

Updated by bmbouter almost 8 years ago

  • Is duplicate of Issue #683: Pulp throws away validation error information from distributors added
Actions #10

Updated by bmbouter almost 8 years ago

  • Status changed from 7 to CLOSED - DUPLICATE
Actions #11

Updated by bmbouter almost 4 years ago

  • Severity set to 2. Medium
Actions #12

Updated by bmbouter almost 4 years ago

  • Tags Pulp 2 added

Also available in: Atom PDF