Project

Profile

Help

Issue #1167

The v2 sync cannot work with a registry that specifies multiple API versions in the Docker-Distribution-API-Version header

Added by rbarlow over 6 years ago. Updated over 2 years ago.

Status:
CLOSED - WONTFIX
Priority:
Normal
Assignee:
-
Start date:
Due date:
Estimated time:
Severity:
2. Medium
Version - Docker:
Platform Release:
Target Release - Docker:
OS:
Triaged:
Yes
Groomed:
No
Sprint Candidate:
No
Tags:
Pulp 2
Sprint:
Quarter:

Description

pulp_docker.plugins.registry.V2Repository.api_version_check() cannot handle the case when the Docker-Distribution-API-Version header specifies multiple versions. This was discussed on Github originally in the pull request that introduced the v2 sync feature. We should identify how the client code will present the case where multiple versions are supported and rework the code to handle that situation.

[0] https://github.com/pulp/pulp_docker/pull/83#discussion_r36096118

History

#1 Updated by mhrivnak over 6 years ago

  • Triaged changed from No to Yes

#2 Updated by bmbouter over 2 years ago

  • Status changed from NEW to CLOSED - WONTFIX

#3 Updated by bmbouter over 2 years ago

Pulp 2 is approaching maintenance mode, and this Pulp 2 ticket is not being actively worked on. As such, it is being closed as WONTFIX. Pulp 2 is still accepting contributions though, so if you want to contribute a fix for this ticket, please reopen or comment on it. If you don't have permissions to reopen this ticket, or you want to discuss an issue, please reach out via the developer mailing list.

#4 Updated by bmbouter over 2 years ago

  • Tags Pulp 2 added

Please register to edit this issue

Also available in: Atom PDF