Project

Profile

Help

Task #112

closed

Add a test to ensure pulp's setup.py versions are the same as the RPM versions

Added by cduryee about 8 years ago. Updated almost 4 years ago.

Status:
CLOSED - WONTFIX
Priority:
Normal
Assignee:
-
Category:
-
Sprint/Milestone:
-
Start date:
Due date:
% Done:

0%

Estimated time:
Platform Release:
Groomed:
No
Sprint Candidate:
No
Tags:
Pulp 2
Sprint:
Quarter:

Description

Pulp is versioned in two places: the spec file, and in various setup.py files. These can get out of sync since tag.sh will not update all of the setup.py files.

We should have an automated test to ensure the versions specificied in the setup.py files match what's in the spec file.

This will be needed for plugins as well as for platform.

Actions #1

Updated by rbarlow about 8 years ago

We don't necessarily have to make this a unit test. It could just be
another thing that run-tests.py does. We may be able to make the
pulp.devel package have to code to perform this test and have each
run-tests.py use it.

Actions #2

Updated by bmbouter almost 4 years ago

  • Status changed from NEW to CLOSED - WONTFIX
Actions #3

Updated by bmbouter almost 4 years ago

Pulp 2 is approaching maintenance mode, and this Pulp 2 ticket is not being actively worked on. As such, it is being closed as WONTFIX. Pulp 2 is still accepting contributions though, so if you want to contribute a fix for this ticket, please reopen or comment on it. If you don't have permissions to reopen this ticket, or you want to discuss an issue, please reach out via the developer mailing list.

Actions #4

Updated by bmbouter almost 4 years ago

  • Tags Pulp 2 added

Also available in: Atom PDF