Project

Profile

Help

Refactor #1066

pulp.server.db.model should be moved to pulp.server.db.models

Added by amacdona@redhat.com over 5 years ago. Updated over 1 year ago.

Status:
CLOSED - WONTFIX
Priority:
High
Assignee:
-
Category:
-
Sprint/Milestone:
-
Start date:
Due date:
% Done:

0%

Estimated time:
Platform Release:
Groomed:
No
Sprint Candidate:
No
Tags:
Pulp 2
Sprint:
Quarter:

Description

This should happen for two reasons:

1. All of our models live there, it should be a plural module name.
2. pulp.server.db.model is currently a package acting as a module. By importing any of the modules in this package, we are forced to import everything that is in model/__init__.py. This creates a precarious situation for circular imports.

The second issue could also be fixed by moving the modules out of the model package and turning model into a real module. Either way, this should happen very soon because we will be updating all the plugins to use the models directly, and we want to make this change before it will break the plugins.

History

#1 Updated by amacdona@redhat.com over 5 years ago

There is at least one (extremely minor) circular import issue caused by this. The fix in that case is to add an extra import that ensures a feet first import. When this is solved, please also remove the extra import in webservices/views/serializers/test_serializers.py. See the note there for more details.

#2 Updated by rbarlow over 5 years ago

  • Status changed from NEW to ASSIGNED
  • Assignee set to rbarlow
  • Platform Release set to master

pcreech is working on this, but I don't see his e-mail address in the available list of Assignees so I'm assigning it to myself for tracking.

#3 Updated by rbarlow almost 5 years ago

  • Status changed from ASSIGNED to NEW
  • Assignee deleted (rbarlow)

This ended up being more complicated than it seemed, so we will have to do it later.

#4 Updated by mhrivnak almost 5 years ago

  • Platform Release deleted (master)

#5 Updated by semyers almost 5 years ago

  • Tags deleted (Easy Fix)

#6 Updated by bmbouter over 1 year ago

  • Status changed from NEW to CLOSED - WONTFIX

#7 Updated by bmbouter over 1 year ago

Pulp 2 is approaching maintenance mode, and this Pulp 2 ticket is not being actively worked on. As such, it is being closed as WONTFIX. Pulp 2 is still accepting contributions though, so if you want to contribute a fix for this ticket, please reopen or comment on it. If you don't have permissions to reopen this ticket, or you want to discuss an issue, please reach out via the developer mailing list.

#8 Updated by bmbouter over 1 year ago

  • Tags Pulp 2 added

Please register to edit this issue

Also available in: Atom PDF